[Alt-photo] problem installing qtr files

Kees Brandenburg workshops at polychrome.nl
Mon Oct 9 18:59:12 UTC 2017


To add some more nerdyness…

After we talked about it I tried to reproduce the long filename error, by installing a profile with 40+ characters. In my case this was a renamed .quad. There is no macos filename limit that prevents long filenames so it is possible to rename a file like that. When installing it with the qtr installer a strange thing happened. The terminal window threw up an error about an inaccesible quad.ppd in /tmp for the printer used. Quad7890 in my case. After this error the whole installation for this Quad7890 printer fell apart and was not functioning anymore. Paper size defaulted to US letter and no qtr profiles visible in the dropdown anymore.

Looking for the error line mentioned in the quad.ppd file in /tmp I actually found a line with the profile_with_a_too_long_name.quad mentioned. So this made me think the actual error is caused by the print system (cups) that can’t work with 40+ characters.  First I tried to remove that line from the ppd and ran the installer again but this didn’t work.

Then I looked in Library/Printers/QTR/quadtone/Quad7890 and there I actually did find a the installedprofile_with_a_too_long_name.quad file!
So QuadToneRip actually installs the too long quad file, and tries to write it to a ppd, but cups can’t work with it!

When I removed the faulty .quad and ran the installer again the problem was solved and the printer was up and running again. It might be a bit different when installing a to long .txt profile.
Of course reintalling the printer does the same.

greetings from the Netherlands,

Kees



On 9 okt. 2017, at 17:22, forums--- via Alt-photo-process-list <alt-photo-process-list at lists.altphotolist.org> wrote:
> 
> 
> The easy (nerdy) way.
> 
> Open terminal and type in this:
> 
> sudo chmod -R 777 /Library/Printers/QTR/quadtone
> 
> 
> Best,
> Walker


More information about the Alt-photo-process-list mailing list