[Libburn-hackers] Re: libburn never finishes burning DVD image

Thomas Schmitt scdbackup at gmx.net
Tue Oct 27 17:01:11 CDT 2009


Hi,

> >   growisofs -dvd-compat -use-the-force-luke=dao \
> >             -Z /dev/dvd0=dvd.iso
Heiko Baums:
> This growisofs command is working perfectly.

That kills my theory. I need to make a new one.


> I've tried it with Xfburn again and selected SAO and it failed again.
> Unfortunately I can't select DAO with Xfburn.

If this controls libburn function
burn_write_opts_set_write_type() then "SAO"
triggered DAO for DVD-R. (It is called SAO with
CD and DAO with DVD. There is also CD DAO but
libburn does not do that.)


> As far as I remember the DVD-R were readable
> in previous tries when I waited 10 or 15 minutes
> after the slow down.

So the main problem seems to be that libburn
does not notice when burning is done.

Another problem seems to be the slowdown.
(I assume you did not get it with growisofs.)


> Today I aborted when the
> slow down began and the DVD-R were not readable. But I don't know if
> this has something to do with the time I was waiting.

Well, if it still was reporting progress then
the abort was too early and prevented proper
closing of track and session. Some data will
be missing, too.


> > Is the drive blinking while the program
> > idles ?
> Yes it does

15 minutes long ?
That would mean the drive is still waiting for
something to happen. 

> I used the standard options for burning. With Xfburn it was TAO. I
> don't know what cdrskin is using by default.

cdrskin reported it was "SAO".
(The default depends on the state of the media
and the nature of the track source.)

> I tried the shell command eject, but it didn't help.

This indicates that either the generic SCSI driver
is stuck or that the drive is not done with
writing.

> growisofs was used by previous K3b
> versions. The K3b version I'm using 1.66.0alpha2 (don't ask me why Arch
> Linux has a alpha version in its stable repository) uses cdrecord
> (wodim/cdrkit).

For DVD this is rather a questionable change.
growisofs beats cdrecord or wodim by far.

Well, everything seems to work for you except
libburn. Grrr.

> But I didn't burn an iso with K3b but a Video DVD with
> the K3b feature "New Video DVD Project".

The problem with the never ending burn is most
likely not related to the track content.

------------------------------------------------

I will try to make theories about why libburn
would not notice the end of the burn or what
could the drive be waiting for.

Sorry for being quite clueless in the moment.


Have a nice day :)

Thomas



More information about the Libburn-hackers mailing list