[lxml-dev] Version in trunk (svn:63387) doesn't compile on Fedora 9.x86_64 / Fedora 10.x86_64

Andreas bolsog at users.sf.net
Fri Mar 27 09:06:44 CDT 2009


Hi,

the version in trunk seems broken for Fedora 9/10.


$ uname -a
Linux rechner1 2.6.27.19-78.2.30.fc9.x86_64 #1 SMP Tue Feb 24 19:44:45
EST 2009 x86_64 x86_64 x86_64 GNU/Linux
and
$ uname -a
Linux rechner2 2.6.27.7-134.fc10.x86_64 #1 SMP Mon Dec 1 22:21:35 EST
2008 x86_64 x86_64 x86_64 GNU/Linux


libxml2 2.7.3
Python 2.5.1

---- snip ----

python setup.py build_ext -i
Building lxml version 2.2-63198.
Building with Cython 0.11.
Using build configuration of libxslt 1.1.24
Building against libxml2/libxslt in the following directory: /usr/lib64
running build_ext
building 'lxml.etree' extension
creating build
creating build/temp.linux-x86_64-2.5
creating build/temp.linux-x86_64-2.5/src
creating build/temp.linux-x86_64-2.5/src/lxml
gcc -pthread -fno-strict-aliasing -DNDEBUG -O2 -g -pipe -Wall
-Wp,-D_FORTIFY_SOURCE=2 -fexceptions -fstack-protector
--param=ssp-buffer-size=4 -m64 -mtune=generic -D_GNU_SOURCE -fPIC
-fPIC -I/usr/include/libxml2 -I/usr/include/python2.5 -c
src/lxml/lxml.etree.c -o
build/temp.linux-x86_64-2.5/src/lxml/lxml.etree.o -w
src/lxml/lxml.etree.c:3299: error: expected ‘=’, ‘,’, ‘;’, ‘asm’ or
‘__attribute__’ before ‘__pyx_v_4lxml_5etree_XSLT_DOC_DEFAULT_LOADER’
src/lxml/lxml.etree.c:3600: error: expected declaration specifiers or
‘...’ before ‘xsltLoadType’
src/lxml/lxml.etree.c:3601: error: expected declaration specifiers or
‘...’ before ‘xsltLoadType’
src/lxml/lxml.etree.c:110035: error: expected declaration specifiers
or ‘...’ before ‘xsltLoadType’
src/lxml/lxml.etree.c: In function
‘__pyx_f_4lxml_5etree__xslt_store_resolver_exception’:
src/lxml/lxml.etree.c:110095: error: ‘__pyx_v_c_type’ undeclared
(first use in this function)
src/lxml/lxml.etree.c:110095: error: (Each undeclared identifier is
reported only once
src/lxml/lxml.etree.c:110095: error: for each function it appears in.)
src/lxml/lxml.etree.c:110095: error: ‘XSLT_LOAD_DOCUMENT’ undeclared
(first use in this function)
src/lxml/lxml.etree.c: At top level:
src/lxml/lxml.etree.c:110242: error: expected declaration specifiers
or ‘...’ before ‘xsltLoadType’
src/lxml/lxml.etree.c: In function ‘__pyx_f_4lxml_5etree__xslt_doc_loader’:
src/lxml/lxml.etree.c:110257: error: ‘__pyx_v_c_type’ undeclared
(first use in this function)
src/lxml/lxml.etree.c:110257: error: ‘XSLT_LOAD_DOCUMENT’ undeclared
(first use in this function)
src/lxml/lxml.etree.c:110280: error: ‘XSLT_LOAD_STYLESHEET’ undeclared
(first use in this function)
src/lxml/lxml.etree.c:110385: error: too many arguments to function
‘__pyx_f_4lxml_5etree__xslt_store_resolver_exception’
src/lxml/lxml.etree.c: In function ‘__pyx_pf_4lxml_5etree_4XSLT___call__’:
src/lxml/lxml.etree.c:113230: error: ‘xsltTransformContext’ has no
member named ‘dict’
src/lxml/lxml.etree.c:113241: error: ‘xsltTransformContext’ has no
member named ‘dict’
src/lxml/lxml.etree.c:113253: error: ‘xsltTransformContext’ has no
member named ‘dict’
src/lxml/lxml.etree.c:113262: error: ‘xsltTransformContext’ has no
member named ‘dict’
src/lxml/lxml.etree.c: In function ‘initetree’:
src/lxml/lxml.etree.c:147853: error:
‘__pyx_v_4lxml_5etree_XSLT_DOC_DEFAULT_LOADER’ undeclared (first use
in this function)
src/lxml/lxml.etree.c:147853: error: ‘xsltDocDefaultLoader’ undeclared
(first use in this function)
error: command 'gcc' failed with exit status 1
make: *** [inplace] Error 1

---- snip ---

Regards

Andreas



More information about the lxml mailing list